<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd"><html lang="en"><!--[if lt IE 7]><html lang="en" class="ie6"><![endif]--><!--[if IE 7]><html lang="en" class="ie7"><![endif]--><!--[if IE 8]><html lang="en" class="ie8"><![endif]--><!--[if IE 9]><html lang="en" class="ie9"><![endif]--><!--[if (gt IE 9)|!(IE)]><html lang="en"><![endif]--><head><META http-equiv="Content-Type" content="text/html; charset=utf-8"><!--Customized Stylesheet Includes - prehead--><!--Customized JS Includes - prehead--><script class="kxct" data-id="qv9l80lgc" data-timing="async" data-version="2.0" type="text/javascript">
            window.Krux||((Krux=function(){Krux.q.push(arguments)}).q=[]);
            (function(){
                var k=document.createElement('script');k.type='text/javascript';k.async=true;
                var m,src=(m=location.href.match(/\bkxsrc=([^&]+)/))&&decodeURIComponent(m[1]);
                k.src = /^https?:\/\/([a-z0-9_\-\.]+\.)?krxd\.net(:\d{1,5})?\/controltag\//i.test(src) ? src : src === "disable" ? "" :
                    (location.protocol==="https:"?"https:":"http:")+"//cdn.krxd.net/controltag?confid=qv9l80lgc";
                var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(k,s);
            }());
        </script><script class="kxint" type="text/javascript">
            
            window.Krux||((Krux=function(){Krux.q.push(arguments);}).q=[]);
            (function(){
                function retrieve(n){
                    var m, k='kxfrankly_'+n,ls=(function(){
                        try{
                            return window.localStorage;
                        }catch(e){
                            return null;
                        }
                    })();
                    if (ls) {
                        return ls[k] || "";
                    } else if (navigator.cookieEnabled) {
                        m = document.cookie.match(k+'=([^;]*)');
                        return (m && unescape(m[1])) || "";
                    } else {
                        return '';
                    }
                }
                Krux.user = retrieve('user');
                Krux.segments = retrieve('segs') ? retrieve('segs').split(',') : [];
            })();
            
        </script><title>Olton City Manager, Marvin Tillman, indicted again - KCBD NewsChannel 11 Lubbock</title>
<meta name="Description" content="A Lamb County grand jury returned a felony indictment alleging Marvin Tillman, Olton City Manager, impersonated a peace officer.  "><meta name="ROBOTS" content="index,follow,noarchive"><meta name="date" content="2017/07/07"><meta name="owner" content="KCBD"><meta name="wn-version" content="ContainerE-Story"><meta name="wn-build" content="release-VIDEO-577-Pagination.6"><meta name="wn-base" content="IIS30"><meta name="wnreadableurl" content="olton-city-manager-marvin-tillman-indicted-again"><meta property="og:title" content="Olton City Manager, Marvin Tillman, indicted again"><meta property="og:type" content="article"><meta property="og:url" content="http://www.kcbd.com/story/35836093/olton-city-manager-marvin-tillman-indicted-again"><meta property="og:image" content="http://kcbd.images.worldnow.com/images/13830926_G.jpg"><meta property="og:description" content="A Lamb County grand jury returned a felony indictment alleging Marvin Tillman, Olton City Manager, impersonated a peace officer.  "><link rel="canonical" href="http://www.kcbd.com/story/35836093/olton-city-manager-marvin-tillman-indicted-again"><meta name="author" content="Michael Cantu"><meta name="twitter:card" content="summary"><meta name="twitter:title" content="Olton City Manager, Marvin Tillman, indicted again"><meta name="twitter:description" content="A Lamb County grand jury returned a felony indictment alleging Marvin Tillman, Olton City Manager, impersonated a peace officer.  "><meta name="twitter:image" content="http://kcbd.images.worldnow.com/images/13830926_G.jpg"><!--Customized Page Includes - Meta-->
<!--
                Page Include: META--><meta http-equiv="X-UA-Compatible" content="IE=edge" /><meta property="fb:app_id" content="378927422184630"/><link rel="image_src" href="http://kcbd.images.worldnow.com/images/1801869_G.png" /><meta property="fb:admins" content="644426401" /><meta property='article:publisher' content='http://www.facebook.com/KCBDNewsChannel11' /><meta property="twitter:account_id" content="108319677" /><meta name="twitter:site" content="@KCBD11" /><meta name="twitter:creator" content="@KCBD11" /> <!--
                END Page Include: META-->

<link type="text/css" rel="stylesheet" media="all" href="http://content.worldnow.com/global/css/_pub/platform.min.css?ver=release-VIDEO-577-Pagination.6_7.3.9.93">
<link type="text/css" rel="stylesheet" media="all" href="http://kcbd.images.worldnow.com/interface/css/container-e.css?ver=2017-05-26%2014%3A11%3A06_7.3.9.93">

<link rel="stylesheet" media="print" href="http://content.worldnow.com/global/css/_pub/print/story.css?ver=7.3.9.93_release-VIDEO-577-Pagination.6" type="text/css"><!--
            [if lt IE 6]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/iequirks.css?ver=release-VIDEO-577-Pagination.6"><![endif]
        -->
<!--
            [if lt IE 7]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/ie6quirks.css?ver=release-VIDEO-577-Pagination.6"><![endif]
        --><!--
            [if lt IE 10]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/ie9quirks.css?ver=release-VIDEO-577-Pagination.6"><![endif]
        -->
<!--MENU INCLUDES--><style type="text/css">#menu69 UL
                    , #menu69 .wnHorizontal { background-color: #1b4f89; font-family: Arial; font-size: 12px; font-weight: 700; color: #ffffff; }
                #menu69 A,
                    #menu69 LI.wnOn .wnSublevel A,
                    #menu69 LI.wnOn .wnSublevel LI.wnOn .wnLevel3 A { font-family: Arial; font-size: 12px; font-weight: 700; color: #ffffff; }
                #menu69 .wnHorizontal .wnDynamic .wnMenuTypeText
                        .wnLevel1 LI.wnHasSublevel .wnMiddle SPAN { padding-right: 15px; }
                #menu69
                        .wnLevel1 LI.wnHasSublevel .wnMiddle SPAN { background: url('http://kcbd.images.worldnow.com/images/static/gfx/nav_tridown.gif') no-repeat 98% 50%; }
                #menu69
                        .wnLevel1 LI.wnHasSublevel .wnLevel2 .wnMiddle SPAN { background: none; }
            #menu69 UL LI.wnOn { background-color: #1b4f89; color: #ffffff; }
                    #menu69 LI.wnOn A,
                        #menu69 LI.wnOn .wnSublevel LI.wnOn A,
                        #menu69 LI.wnOn .wnSublevel LI.wnOn .wnLevel3 LI.wnOn A { color: #ffffff; }
                    #menu69 .wnSublevel { background-color: #1b4f89;  }
                #menu69 .wnSublevel A { border : 1px #1b4f89 solid; border-top: none; }
                        #menu69 .wnSublevel .wnFirstNode { border-top : 1px #1b4f89 solid; }
                        #menu69 .wnHorizontal .wnDynamic .wnMenuTypeText .wnSublevel LI.wnHasSublevel A { padding-right: 9px; }
                #menu69 .wnSublevel LI.wnHasSublevel A { background: url('http://kcbd.images.worldnow.com/images/static/gfx/nav_tri.gif') no-repeat 98% 50%; }
                #menu69 .wnSublevel LI.wnHasSublevel .wnLevel3 A { background: none; }
            #menu69 .wnSublevel LI.wnOn { background-color: #1b4f89;  }
                    #menu69 .wnRight .wnMiddle { background: url('http://kcbd.images.worldnow.com/images/static/gfx/nav_bg_off.gif') repeat-x; }
                    #menu69 LI.wnOn .wnMiddle { background-image: url('http://kcbd.images.worldnow.com/images/static/gfx/nav_bg_on.gif'); }
                
</style>

<!--END MENU INCLUDES-->
<script type="text/javascript">
            var wng_pageInfo = {
            affiliateName : 'KCBD',
            affiliateId : '69',
            baseUrl : 'www.KCBD.com',
            includesDomain : 'http://content.worldnow.com',
            includesVersion : '7.3.9.93',
            videoHelpPage : '/global/story.asp?s=1343812&displayHelp=true',
            videoHelpPageMac : '/global/Story.asp?s=2918340&displayHelp=true',
            social : {mdPartnerID : '105',mdPartnerDomain : 'http://dub.kcbd.com'},
            registrationId : '666278',
            registrationURL:'registration',
            readableURLenabled: 'True',
            imageDomain : 'http://kcbd.images.worldnow.com'
            };
            
wng_pageInfo.body = {};
wng_pageInfo.taxonomy = {};
wng_pageInfo.build='release-VIDEO-577-Pagination.6';
wng_pageInfo.template='ContainerE-Story';
wng_pageInfo.isPreviewSite=false;
wng_pageInfo.containerType='S';
wng_pageInfo.ownerAffiliateName='KCBD';
wng_pageInfo.ownerAffiliateId=parseInt('69',10);
wng_pageInfo.containerId=parseInt('35836093',10);
wng_pageInfo.containerType='S';
wng_pageInfo.containerClass='story';
wng_pageInfo.contentClassification='News';
wng_pageInfo.userId=parseInt('',10);
wng_pageInfo.permaLink='/story/35836093/olton-city-manager-marvin-tillman-indicted-again';
wng_pageInfo.content_authors='Michael Cantu';
wng_pageInfo.headline='Olton City Manager, Marvin Tillman, indicted again';
wng_pageInfo.pageTitle='Olton City Manager, Marvin Tillman, indicted again - KCBD NewsChannel 11 Lubbock';
wng_pageInfo.pageTitleTag='KCBD NewsChannel 11 Lubbock';
wng_pageInfo.pageTitleTagAs='Suffix';
wng_pageInfo.body._id='WNAffKCBD';
wng_pageInfo.body._class='wnContainerType-story wnCenterAlignment';
wng_pageInfo.isMobile=false;
wng_pageInfo.taxonomy.level1='';
wng_pageInfo.taxonomy.level2='';
wng_pageInfo.taxonomy.level3='';
wng_pageInfo.simpleResponsiveBranding=false;
wng_pageInfo.buildInfo = wng_pageInfo.build.match(/[0-9]+/g) || [0,0,'local'];
</script>
<script>
        var wng_pageInfo = window.wng_pageInfo || {};
        wng_pageInfo.ads = {};
        /*Ad wnsz_1 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_14 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_16 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_17 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_18 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_20 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_21 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_22 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_23 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_24 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_26 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_27 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_28 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["40"]={id:"40",wnsz:"40",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'dom',aff:'KCBD'},width:468,height:60,wncc:"News",parent:"WNAd40",type:"dom",realvu:"",application:"printable"};
/*Ad wnsz_41 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_42 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["43"]={id:"43",wnsz:"43",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'dom',aff:'KCBD'},width:300,height:250,wncc:"News",parent:"WNAd43",type:"dom",realvu:"",sizes:[[300,250],[300,600]],application:"banner"};
/*Ad wnsz_44 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_45 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_46 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_47 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_49 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_50 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["52"]={id:"52",wnsz:"52",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'dom',aff:'KCBD'},width:300,height:250,wncc:"News",parent:"WNAd52",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_54 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_63 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_85 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["86"]={id:"86",wnsz:"86",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'inline',aff:'KCBD'},width:980,height:30,wncc:"News",parent:"WNAd86",type:"inline",realvu:"",sizes:[[728,90],[980,30],[970,250]],application:"banner"};
</script>
<script type="text/javascript" src="http://kcbd.images.worldnow.com/interface/js/wnaffiliateconfig.js?ver=2017-05-26%2014%3A11%3A06_7.3.9.93"></script>
<script type="text/javascript" src="http://content.worldnow.com/global/js/_pub/KCBD.config.js?ver=release-VIDEO-577-Pagination.6_7.3.9.93"></script>
<script type="text/javascript" src="http://content.worldnow.com/global/js/_pub/platform.min.js?ver=release-VIDEO-577-Pagination.6_7.3.9.93"></script>
<!--Ad sense not required CURRENT--><script type="text/javascript">
            if(Worldnow.EventMan){Worldnow.EventMan.event('head-javascript-done');}
        </script><!--
                Page Include: HEAD--><link href='http://fonts.googleapis.com/css?family=Open+Sans:400italic,400,700|Open+Sans+Condensed:700,300' rel='stylesheet' type='text/css'><script src="http://ftpcontent.worldnow.com/wncustom/custom/raycom/2015/custom-master.js"></script><script src="http://ftpcontent.worldnow.com/wncustom/custom/kcbd/2015/custom.js"></script><link rel="stylesheet" type="text/css" href="http://ftpcontent.worldnow.com/wncustom/custom/raycom/2015/custom-master.css" /><link rel="stylesheet" type="text/css" href="http://ftpcontent.worldnow.com/wncustom/custom/kcbd/2015/custom.css" /></script><script src="http://ftpcontent4.worldnow.com/raycom/secondaryNav/2015/secnav-kcbd.js"></script><script type="text/javascript" src="http://ftpcontent4.worldnow.com/raycom/custom/2015/raycom_custom_global.js"></script><link rel="stylesheet" type="text/css" href="http://ftpcontent4.worldnow.com/raycom/custom/2015/raycom_custom_global.css" /><script type="text/javascript" src="http://ftpcontent4.worldnow.com/kcbd/custom/2015/kcbd-custom.js"></script><link rel="stylesheet" type="text/css" href="http://ftpcontent4.worldnow.com/kcbd/custom/2015/kcbd-custom.css" /><!--
                END Page Include: HEAD-->
<!--Customized Page Includes - Head--><link type="text/css" rel="stylesheet" href="//ftpcontent.worldnow.com/professionalservices/clients/kcbd/2015/custom.css"><script src="//ftpcontent.worldnow.com/professionalservices/clients/kcbd/2015/custom.js"></script></head><body id="WNAffKCBD" class="wnContainerType-story wnCenterAlignment story"><!--Google Tag Manager--><noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-KW85V8" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
        new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
        j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
        '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
        })(window,document,'script','dataLayer','GTM-KW85V8');</script><!--End Google Tag Manager--><!--Google Tag Manager - Analytics Key available for GTM implementation-->
<script>(function(){ franklyDataLayer = window.franklyDataLayer || []; var w = window.Worldnow || {}, b = w.Beacon || null; if(b) { franklyDataLayer.push(b.get('page',{ "ua_id":'UA-82494642-149' ,"dma":'143' ,"group":'Raycom'})); } }());</script>
<!--Google Tag Manager--><noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-WV2QLD" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
        new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
        j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
        '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
        })(window,document,'script','franklyDataLayer','GTM-WV2QLD');</script><!--End Google Tag Manager-->
<script>(function(w){ var e = w.EventMan || null; var b = w.Beacon || null; e.event('analytics-page',b.get('page')); })(window.Worldnow || {}); (function(w){ var e = w.EventMan || null; if(e) {e.event('bodystart');} })(window.Worldnow || {});</script>
<div id="WNHeaderScripts"></div><div id="WNHeader"><h1>Olton City Manager, Marvin Tillman, indicted again - KCBD NewsChannel 11 Lubbock</h1><div class="wnContainerMemberSearch" id="WNContainerMemberSearch-headertop"><div class="wnMemberCenter wnMemberCenter-left wnMemberCenter-loggedOut" id="WNMemberCenter-headertop" refresh="1"><strong>Member Center:</strong><ul><li class="wnMemberOption-accountCreate wnMemberType-nonuser"><a href="javascript: WNMemberCenterManager.gotoLoginLink('create')">Create Account</a><span class="wnSeparator">|</span></li><li class="wnMemberOption-logIn wnMemberType-nonuser"><a href="javascript: WNMemberCenterManager.gotoLoginLink('login')">Log In</a><span class="wnSeparator"></span></li><li class="wnMemberOption-accountManage wnMemberType-user"><a href="javascript: WNMemberCenterManager.gotoLoginLink()">Manage Account</a><span class="wnSeparator">|</span></li><li class="wnMemberOption-logOut wnMemberType-user"><a href="javascript:WNMemberCenterManager.gotoLoginLink('logout')">Log Out</a><span class="wnSeparator"></span></li></ul></div>
<!--END wnMemberCenter-->
<div class="wnSearchBox wnSearchBox-right" id="WNSearchBox-headertop"><form method="get" onsubmit="return wnValidateSearchTerm(this,0)" action="/Global/searchresults.asp"><input type="radio" name="vendor" value="ez" id="WNSearchBox-headertop-ez" class="wnVendorChoice" checked><label for="WNSearchBox-headertop-ez">SITE SEARCH</label><input type="radio" name="vendor" value="google_cs" id="WNSearchBox-headertop-google_cs" class="wnVendorChoice"><label for="WNSearchBox-headertop-google_cs">WEB SEARCH BY <img src='http://images.worldnow.com/global/images/google/google-logo.gif' alt='Google' class='wnSearchBoxLabelImg-google'></label><input type="text" class="wnQueryText" name="qu" size="20" value=""><input type="submit" class="wnSubmit" value="Go"></form></div><!--END wnSearchBox-->
</div><!--END wnContainerMemberSearch-->
<div id="WNBranding"><img id="WNBrandingImage" usemap="#wnBrandingMap" alt="" border="0" src="http://kcbd.images.worldnow.com/images/static/hdr/hdr_branding.jpg"><map name="wnBrandingMap"><area shape="rect" coords="0,0,980,1000" target="_top" href="/"></map><img id="WNPrintBrandingImage" style="display:none;" border="0" width="607" height="37" src="http://kcbd.images.worldnow.com/images/static/hdr/hdr_607x37.gif"></div><!--END WNBranding--></div><!--END WNHeader--><div id="WNColsAll" class="columnsall wnColConfig"><div id="WNMenuCol1">
<!--MENU START-->
<div id="menu69" class="wnMainMenu"><div class="wnHorizontal"><div class="wnDynamic"><div class="wnMenuTypeText"><ul class="wnLevel1" id="submenu69"><li class="wnFirstNode" id="menu69_1-C4401"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/">HOME</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu69_1-C4401"><li class="wnFirstNode" id="menu69_1_3-C6335"><span><a href="/category/6335/kcbd-staff">KCBD Staff</a></span></li><li class="" id="menu69_1_4-C91476"><span><a href="/category/91476/newschannel-11s-newsstream">KCBD NewsStream</a></span></li><li class="" id="menu69_1_5-C225469"><span><a href="/category/225469/pay-it-forward">Pay It Forward</a></span></li><li class="" id="menu69_1_6-S1552924"><span><a href="/story/1552924/main-contact-list">Main Contact List</a></span></li><li class="" id="menu69_1_7-L753366"><span><a href="http://kcbd.com/livestream">KCBD Live Stream</a></span></li><li class="" id="menu69_1_8-L772697"><span><a href="/link/772697/download-kcbd-apps">Download KCBD Apps</a></span></li><li class="" id="menu69_1_9-L785435"><span><a href="/category/323939/behind-the-badge-with-shaley-sanders">Behind the Badge</a></span></li><li class="" id="menu69_1_10-L786332"><span><a href="/category/324494/duff-on-digital">Duff on Digital</a></span></li><li class="" id="menu69_1_1-L734683"><span><a href="/category/81433/consider-this-with-dan-jackson">Consider This</a></span></li><li class="" id="menu69_1_2-C213378"><span><a href="/category/213378/heartwarming-stories">Stories to make you happy</a></span></li></ul></li><li class="" id="menu69_2-C4403"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/4403/news">News</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu69_2-C4403"><li class="wnFirstNode" id="menu69_2_1-C6128"><span><a href="/category/6128/food-for-thought">Food For Thought</a></span></li><li class="" id="menu69_2_2-L785435"><span><a href="/category/323939/behind-the-badge-with-shaley-sanders">Behind the Badge</a></span></li><li class="" id="menu69_2_3-C87923"><span><a href="/category/87923/newschannel-11-investigates">Investigates</a></span></li><li class="" id="menu69_2_4-L779550"><span><a href="/link/779550/download-the-kcbd-news-app">Download the KCBD News App</a></span></li></ul></li><li class="" id="menu69_3-C240190"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/video">VIDEO</a></span></span></span></span></li><li class="" id="menu69_4-C4402"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/weather">WEATHER</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu69_4-C4402"><li class="wnFirstNode" id="menu69_4_3-L687775"><span><a href="http://www.kcbd.com/category/236484/weather-resource-center">Personal Forecast Emails</a></span></li><li class="" id="menu69_4_5-L687774"><span><a href="http://www.kcbd.com/category/236484/weather-resource-center"> KCBD's First Alert Weather Resources</a></span></li><li class="" id="menu69_4_1-S170255"><span><a href="/story/170255/regional-road-condition-phone-numbers-and-information">Road Condition Phone Numbers &amp; Information</a></span></li><li class="" id="menu69_4_2-L125450"><span><a href="/link/125450/the-latest-rain-totals-for-the-south-plains">Latest Rain Totals for the South Plains</a></span></li><li class="" id="menu69_4_4-L779551"><span><a href="/link/779551/download-the-kcbd-weather-app">Download the KCBD Weather App</a></span></li></ul></li><li class="" id="menu69_5-C6127"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/6127/healthwise-with-karin-mccay">HEALTHWISE</a></span></span></span></span></li><li class="" id="menu69_6-C4404"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/4404/sports">SPORTS</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu69_6-C4404"><li class="wnFirstNode" id="menu69_6_1-L751178"><span><a href="/category/56886/2015-end-zone">End Zone Scores</a></span></li><li class="" id="menu69_6_8-C233412"><span><a href="/category/233412/sports-stories">National Sports</a></span></li><li class="" id="menu69_6_2-C270142"><span><a href="/category/270142/raiderzone">RaiderZone</a></span></li><li class="" id="menu69_6_3-L760541"><span><a href="http://www.kcbd.com/category/74973/hoop-madness">Hoop Madness</a></span></li><li class="" id="menu69_6_4-L765294"><span><a href="/category/78135/extra-innings">Extra Innings</a></span></li><li class="" id="menu69_6_5-C59652"><span><a href="/category/59652/i-beat-pete">I Beat Pete</a></span></li><li class="" id="menu69_6_6-C130667"><span><a href="/category/130667/pee-wee-tv">Pee Wee TV</a></span></li><li class="" id="menu69_6_7-L779552"><span><a href="/link/779552/download-the-kcbd-sports-app">Download the KCBD Sports App</a></span></li></ul></li><li class="" id="menu69_7-C52014"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/52014/contests">Contests</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu69_7-C52014"><li class="wnFirstNode" id="menu69_7_1-S32388031"><span><a href="/story/32388031/exciting-tough-talk-contest">Exciting Tough Talk Contest</a></span></li><li class="" id="menu69_7_2-S35696676"><span><a href="/story/35696676/kcbd-yard-of-the-week">KCBD Yard Of The Week</a></span></li><li class="" id="menu69_7_3-S35788369"><span><a href="/story/35788369/kcbd-all-american-eats-contest">KCBD All-American Eats Contest</a></span></li></ul></li><li class="" id="menu69_8-C59662"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/59662/whats-on-tv">What's on TV</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu69_8-C59662"><li class="wnFirstNode" id="menu69_8_1-L38034"><span><a href="javascript:OpenWin('/link/38034/newschannel-11-program-schedule||height=600,width=640,location=no,resizable=yes,scrollbars=yes,toolbar=yes');">TV - Program Schedule</a></span></li><li class="" id="menu69_8_2-L73069"><span><a href="javascript:OpenWin('https://www.jeopardy.com/about/this-week-on-jeopardy||height=768,width=1024,location=no,resizable=yes,scrollbars=yes,toolbar=yes');">Jeopardy</a></span></li><li class="" id="menu69_8_6-S19485867"><span><a href="/story/19485867/closed-captioning-on-kcbd-newschannel-11">Closed Captioning on KCBD NewsChannel 11</a></span></li><li class="" id="menu69_8_3-L613898"><span><a href="javascript:OpenWin('http://www.lubbock.thistv.com/||height=,width=,location=yes,resizable=yes,scrollbars=no,toolbar=yes');">This TV</a></span></li><li class="" id="menu69_8_4-L73073"><span><a href="javascript:OpenWin('http://www.insideedition.com/||height=,width=,location=no,resizable=yes,scrollbars=yes,toolbar=yes');">Inside Edition</a></span></li><li class="" id="menu69_8_5-L73067"><span><a href="javascript:OpenWin('http://www.wheeloffortune.com/||height=,width=,location=no,resizable=yes,scrollbars=yes,toolbar=yes');">Wheel of Fortune</a></span></li></ul></li><li class="" id="menu69_9-C87923"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/87923/newschannel-11-investigates">Investigates</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu69_9-C87923"><li class="wnFirstNode" id="menu69_9_1-S34142811"><span><a href="/story/34142811/submit-a-tip">Submit A Tip</a></span></li><li class="" id="menu69_9_2-L785435"><span><a href="/category/323939/behind-the-badge-with-shaley-sanders">Behind the Badge</a></span></li><li class="" id="menu69_9_3-C319962"><span><a href="/category/319962/fatal-dose-fentanyl-sweeping-the-south-plains">Fatal dose: Fentanyl sweeping the South Plains</a></span></li></ul></li><li class="" id="menu69_10-C6334"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/6334/contact-us">Contact Us</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu69_10-C6334"><li class="wnFirstNode" id="menu69_10_1-L772697"><span><a href="/link/772697/download-kcbd-apps">Download KCBD Apps</a></span></li></ul></li></ul><div class="wnClearMenu" id="clearmenu69"></div></div></div></div><div id="spacermenu69" class="wnMenuSpacer"></div></div><script type="text/javascript">
            if (window.wnMenuSetup) {
            wnMenuSetup('menu69', 
            { alignment : '', timeoutDuration : '', highlightActiveNodes : false, level1ArrowPadding : '15', levelBorderWidths : { level1 : { top : '0' , right : '0' , bottom : '0' , left : '0' } , level2 : { top : '1' , right : '1' , bottom : '1' , left : '1' } } }
        );
            }
        </script>
<!--MENU END-->
</div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNMenuCol1done');</script>
<!--END WNMenuCol1-->
<div id="WNCols234-5" class="columns wnColConfig"><div class="debug hide" data-debug="Display Size 23 attempting to load..."></div><div class="debug hide" data-debug="Display Size 40 attempting to load..."></div><div id="WNCols23-4" class="wnColConfig4"><div class="debug hide" data-debug="Display Size 33 attempting to load..."></div><div id="WNAd86" class="wnad wnad86">
<script>wnad_86.load();</script></div>
<!--END wnAdSize-->
<div id="WNCol23" class="wnColConfig2 columns col2 col3"><div id="WNCol23Top"><div class="debug hide" data-debug="Display Size 29 attempting to load..."></div></div><!--END WNCol23Top-->
<div id="WNContainerStory" class=""><ul id="WNStoryUtils"><li class="wnSUAddThis"></li></ul><!--END WNStoryUtils-->
<div id="WNStoryHeader">
<h3 class="">Olton City Manager, Marvin Tillman, indicted again</h3>
<time datetime="2017-07-07T21:10:13Z" class="publisheddate wn-time gmt dst-switch">2017-07-07T21:10:13Z</time><time datetime="2017-07-07T21:12:30Z" class="updateddate wn-time gmt dst-switch">2017-07-07T21:12:30Z</time><style>time.prefixdate:before{content:'Posted: ';}time.prefixdate:before{content:'Updated: ';}</style><div id="WNStoryByline" class="bylines wn-row"><div class="byline wn-row"><span class="author">By Michael Cantu, Digital Content Producer</span><div class="simple"><span class="email item"><a target="_self" title="" href="mailto:mcantu@kcbd.com?body=http://www.KCBD.com/story/35836093/olton-city-manager-marvin-tillman-indicted-again">Email</a></span></div><div class="wn-anchor"><a href="#" class="connect">Connect</a><div class="connect off"><div class="email item"><a target="_self" title="" href="mailto:mcantu@kcbd.com?body=http://www.KCBD.com/story/35836093/olton-city-manager-marvin-tillman-indicted-again">mcantu@kcbd.com</a></div></div></div></div></div><div class="debug hide" data-debug="Display Size 37 attempting to load..."></div><!--DISPLAY SIZE 37: -->
<div id="WNDS37" class="wnDS37 wnDSContainer-standard wnDS">
<div class="wnDSItems-standard">
<div id="divWNStoryVideoDS37" style="&#xA;          height: 485px; overflow: hidden; position: relative;&#xA;        "><div id="divWNGalleryDS37" style="&#xA;            top: 354px; z-index: 1000; position: absolute;&#xA;          "></div><div id="divWNVideoCanvasDS37" style="position: absolute; top: 0px;"></div><script type="text/javascript">
          var widgetVideoCanvasDS37 = new WNVideoWidget("WNVideoCanvas2", "divWNVideoCanvasDS37", "DS37");
          widgetVideoCanvasDS37.SetStylePackage("flatlight");
          widgetVideoCanvasDS37.SetSkin(CANVAS_SKINS.flat.ebony);
          widgetVideoCanvasDS37.SetWidth("630");
          widgetVideoCanvasDS37.SetHeight("355");
          widgetVideoCanvasDS37.SetVariable("landingPage", document.location.href);
          widgetVideoCanvasDS37.SetVariable("clipId", "13474244");
          widgetVideoCanvasDS37.SetVariable("transportShareButtons", "cc");
          widgetVideoCanvasDS37.SetVariable("controlsType", "fixed");
          
            widgetVideoCanvasDS37.SetEmbeddedGallery("wnstory", "35836093");
          

            try {
                if(wn.video.site.enablestorypageautoplay) {
                    widgetVideoCanvasDS37.SetVariable('isAutoStart', 'true');
                }
            }
            catch(e) {}

          widgetVideoCanvasDS37.RenderWidget();
          
            galleryPlacement = 'both';
            if (navigator.userAgent.match(/(iPhone|iPod|iPad)/) ||
            galleryPlacement != 'inside')
            {
            containerHeight = 355 + 130;
            $('#divWNStoryVideoDS37').css('height',containerHeight + 'px');

            var WNGalleryDS37 = new WNVideoWidget("WNGallery", "divWNGalleryDS37", "DS37");
            WNGalleryDS37.SetStylePackage("flatlight");
            WNGalleryDS37.SetVariable("hasSearch", "false");
            WNGalleryDS37.SetVariable("rows", "1");
            WNGalleryDS37.SetVariable("columns", "2");
            WNGalleryDS37.SetVariable("showTooltip", "true");
            WNGalleryDS37.SetVariable("tabHeight", "0");
            WNGalleryDS37.SetVariable("tabFontSize", "0");
            WNGalleryDS37.SetVariable("dropDownFontSize", "0");
            WNGalleryDS37.SetVariable("videoListImageWidth", "140");
            WNGalleryDS37.SetVariable("videoListImageHeight", "79");
            WNGalleryDS37.SetVariable("storyId", "35836093");
            WNGalleryDS37.SetVariable("clipId", "13474244");
            WNGalleryDS37.SetWidth(630);
            WNGalleryDS37.SetHeight(130);


            try {
              if (wn.video.site.storyPageContinuousPlay) {
                WNGalleryDS37.SetVariable("isContinuousPlay", true);
              } else {
                WNGalleryDS37.SetVariable("isContinuousPlay", false);
              }

            } 
            catch(e) {}

            try {
              if (wn.video.site.disableSinglePageClipInStory) {
                WNGalleryDS37.SetVariable("disableSinglePageClipInStory", true);
              } else {
                WNGalleryDS37.SetVariable("disableSinglePageClipInStory", false);
              }
            }
            catch(e) {}

            WNGalleryDS37.RenderWidget();
            }
          </script></div></div><!--END wnDSItems-->
</div><!--
                END wnDS37-->
</div><!--END WNStoryHeader-->
<div id="WNStoryRelatedBox" class="wnRight" WNCollapse="true"><div class="debug hide" data-debug="Display Size 20 attempting to load..."></div><div class="wnStoryBodyGraphic wnImageWidth-180"><img src="http://kcbd.images.worldnow.com/images/13830926_G.jpg" alt="Marvin Tillman (Source: Lamb County Sheriff's Office)" title="Marvin Tillman (Source: Lamb County Sheriff's Office)" border="0" width="180">
<span>Marvin Tillman (Source: Lamb County Sheriff's Office)</span></div></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNStoryRelatedBoxdone');</script>
<!--END WNStoryRelatedBox-->
<div id="WNStoryBody" class=" withRelated right"><span id="WNStoryDateline">OLTON, TX (KCBD) -
            </span><p>A Lamb County grand jury returned a felony indictment alleging Marvin Tillman, Olton City Manager, impersonated a peace officer.</p><p>This indictment stems from a Texas Rangers investigation that resulted in a felony complaint against Tillman in May, according to <a href="https://www.facebook.com/312499497003/photos/a.10150136768842004.332486.312499497003/10156271140977004/?type=3&amp;theater">The Olton Enterprise</a>. This complaint alleges he impersonated a peace officer by operating an official marked police vehicle.</p><p>The complaint goes on to say he was attempting to slow down Isidro Romo by activating emergency lights of said vehicle, according to the Enterprise.&nbsp;</p><p>Tillman was originally arrested on May 5 after a grand jury handed up two third-degree felony charges, which stemmed from that Texas Rangers investigation.&nbsp;</p><p>Tillman also still remains on the city payroll, according to The Enterprise. And after Tillman&rsquo;s arrest Olton Mayor Mark McFadden said Tillman wanted to take a vacation and formally announced he would be away from city offices for a two-week period. &nbsp;On May 12, he was put on paid leave for 60 days.</p><p><a href="http://www.kcbd.com/story/35355221/texas-rangers-arrest-olton-city-manager-on-charges-of-theft-impersonating-an-officer">RELATED STORY:&nbsp;Texas Rangers arrest Olton city manager on charges of theft, impersonating an officer</a></p><p><a href="http://www.kcbd.com/story/35415248/olton-city-manager-put-on-paid-administrative-leave-for-60-days-after-arrest-indictment">RELATED STORY:&nbsp;Olton City Manager put on paid administrative leave for 60 days after arrest, indictment</a></p><p><a href="http://www.kcbd.com/story/35419627/olton-residents-react-to-city-manager-placed-on-paid-leave">RELATED STORY:&nbsp;Olton residents react to city manager placed on paid leave</a></p><p><a href="http://www.kcbd.com/story/35383744/olton-city-council-announces-special-meeting-to-discuss-employment-status-of-city-manager">RELATED STORY:&nbsp;Olton City Council announces special meeting to discuss employment status of city manager</a></p><p><em>Copyright 2017 <a href="http://www.kcbd.com">KCBD</a>. All rights reserved.</em></p></div><!--END WNStoryBody-->
<div id="wnSocialToolsSection"><div id="WNMobdub"></div></div>
<div class="wnClear"></div></div><!--END WNContainerStory-->
<div id="WNCol2" class="column col2"><div class="debug hide" data-debug="Display Size 16 attempting to load..."></div><div class="debug hide" data-debug="Display Size 8 attempting to load..."></div><div class="debug hide" data-debug="Display Size -20 attempting to load..."></div><div class="debug hide" data-debug="Display Size 45 attempting to load..."></div><div class="debug hide" data-debug="Display Size 11 attempting to load..."></div><div id="WNAd52" class="wnad wnad52">
<script>wnad_52.load();</script></div>
<!--END wnAdSize-->
<div class="debug hide" data-debug="Display Size 6 attempting to load..."></div></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol2done');</script>
<!--END WNCol2-->
<div id="WNCol23Bottom"><div class="debug hide" data-debug="Display Size 31 attempting to load..."></div></div><!--END WNCol23Bottom-->
</div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol23done');</script>
<!--END WNCol23-->
<div id="WNCol4" class="column col4"><!--
                        Column 4 Layout Configuration: 8-->
<div class="debug hide" data-debug="Display Size 76 attempting to load..."></div><div id="WNAd43" class="wnad wnad43">
<script>wnad_43.load();</script></div>
<!--END wnAdSize-->
<div class="debug hide" data-debug="Display Size 64 attempting to load..."></div><!--Start of Display Size: Headline Box - Col 4 (78)--><div class="wnBlock displaySize displaySizeId78 headlineBox" id="DisplaySizeId78"><ul class="wnGroup contentGroup odd collapsible closed last"><li class="wnItem header"><h3><span class="text sectionTitle">Local News on KCBD.com</span><span class="text abridgedHeadline">News</span><a class="wnContent more enabled" href="/category/4403/news"><span class="text">More&gt;&gt;</span></a><div class="wnClear"></div></h3></li><li class="wnItem advertisement">
</li><li class="wnItem feature NewsAPNational story priority-1 odd displaySizeId-7 odd-7"><meta content="News - AP-National"><meta content="2017-07-07 20:36:04"><h4 class="wnContent headline"><a href="/story/35835771/police-williams-legally-entered-intersection-before-crash"><span class="text">Police: Williams legally entered intersection before crash</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/35835771/police-williams-legally-entered-intersection-before-crash"><span class="text">Police: Williams legally entered intersection before crash</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate"><label class="wnContent timestamp publisheddate">Posted: </label><span class="wnContent timestamp servertime">Friday, July 7 2017 4:36 PM EDT</span><span class="wnContent timestamp gmttime">2017-07-07 20:36:04 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="timestamps wnDate updateddate"><label class="wnContent timestamp">Updated: </label><span class="wnContent timestamp servertime">Friday, July 7 2017 9:20 PM EDT</span><span class="wnContent timestamp gmttime">2017-07-08 01:20:17 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35835771/police-williams-legally-entered-intersection-before-crash"><img border="0" width="90" data-path="http://APMOBILE.images.worldnow.com/images/14330074_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35835771/police-williams-legally-entered-intersection-before-crash"><img border="0" width="90" data-path="http://APMOBILE.images.worldnow.com/images/14330074_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>The cars driven in a fatal crash involving tennis star Venus Williams could be examined by experts next week.</p></span></div><div class="wnContent summary"><span class="text"><p>The cars driven in a fatal crash involving tennis star Venus Williams could be examined by experts next week.</p></span></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-2 even displaySizeId-7 even-7"><meta content="News"><meta content="2017-07-07 22:07:22"><h4 class="wnContent headline"><a href="/story/35836588/wolfforth-police-on-scene-near-highway-62"><span class="text">UPDATE: Wolfforth police confirm industrial accident led to man's death</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/35836588/wolfforth-police-on-scene-near-highway-62"><span class="text">UPDATE: Wolfforth police confirm industrial accident led to man's death</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate updateddate"><label class="wnContent timestamp">Updated: </label><span class="wnContent timestamp servertime">Friday, July 7 2017 8:06 PM EDT</span><span class="wnContent timestamp gmttime">2017-07-08 00:06:23 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35836588/wolfforth-police-on-scene-near-highway-62"><img border="0" width="90" data-path="http://kcbd.images.worldnow.com/images/14329412_G.jpg" title="Source: Caleb Holder, KCBD" alt="Source: Caleb Holder, KCBD"></a><span class="caption left width90"><span class="text">Source: Caleb Holder, KCBD</span></span></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35836588/wolfforth-police-on-scene-near-highway-62"><img border="0" width="90" data-path="http://kcbd.images.worldnow.com/images/14329412_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>&nbsp;A worker with Allen Butler Construction Inc. is dead after he fell in the path of machinery near Highway 62 and Private Road 1320.</p> </span></div><div class="wnContent summary"><span class="text"><p>&nbsp;A worker with Allen Butler Construction Inc. is dead after he fell in the path of machinery near Highway 62 and Private Road 1320.</p></span></div><div class="wnClear"></div></li><li class="wnItem feature NewsAPNational story priority-3 odd displaySizeId-7 odd-7"><meta content="News - AP-National"><meta content="2017-07-07 07:05:37"><h4 class="wnContent headline"><a href="/story/35830795/germany-hosts-difficult-g-20-talks-on-trade-climate"><span class="text">Germany hosts 'difficult' G-20 talks on trade, climate</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/35830795/germany-hosts-difficult-g-20-talks-on-trade-climate"><span class="text">Germany hosts 'difficult' G-20 talks on trade, climate</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate"><label class="wnContent timestamp publisheddate">Posted: </label><span class="wnContent timestamp servertime">Friday, July 7 2017 3:05 AM EDT</span><span class="wnContent timestamp gmttime">2017-07-07 07:05:37 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="timestamps wnDate updateddate"><label class="wnContent timestamp">Updated: </label><span class="wnContent timestamp servertime">Friday, July 7 2017 7:46 PM EDT</span><span class="wnContent timestamp gmttime">2017-07-07 23:46:45 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35830795/germany-hosts-difficult-g-20-talks-on-trade-climate"><img border="0" width="90" data-path="http://APMOBILE.images.worldnow.com/images/14323350_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35830795/germany-hosts-difficult-g-20-talks-on-trade-climate"><img border="0" width="90" data-path="http://APMOBILE.images.worldnow.com/images/14323350_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>The Group of 20 summit is getting underway in Hamburg, with terrorism, global trade and climate change among the issues on the agenda as leaders gather under tight security.</p> </span></div><div class="wnContent summary"><span class="text"><p>The Group of 20 summit is getting underway in Hamburg, with terrorism, global trade and climate change among the issues on the agenda as leaders gather under tight security.</p></span></div><div class="wnClear"></div></li><li class="wnItem feature Station50 story priority-4 even displaySizeId-7 even-7 collapsed"><meta content="Station 50"><meta content="2017-07-05 04:22:23"><h4 class="wnContent headline"><a href="/story/35812116/police-using-narcan-on-overdosed-k-9-cops"><span class="text">Police using Narcan on overdosed K-9 cops</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/35812116/police-using-narcan-on-overdosed-k-9-cops"><span class="text">Police using Narcan on overdosed K-9 cops</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate updateddate"><label class="wnContent timestamp">Updated: </label><span class="wnContent timestamp servertime">Friday, July 7 2017 6:42 PM EDT</span><span class="wnContent timestamp gmttime">2017-07-07 22:42:18 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35812116/police-using-narcan-on-overdosed-k-9-cops"><img border="0" width="90" data-path="http://RAYCOMGROUP.images.worldnow.com/images/14302976_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35812116/police-using-narcan-on-overdosed-k-9-cops"><img border="0" width="90" data-path="http://RAYCOMGROUP.images.worldnow.com/images/14302976_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Overdosed police dogs are increasingly getting immediate help from their partners in the form of Narcan rather than having to wait to be taken to vets.&nbsp;</p> </span></div><div class="wnContent summary"><span class="text"><p>Overdosed police dogs are increasingly getting immediate help from their partners in the form of Narcan rather than having to wait to be taken to vets.&nbsp;</p></span></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-5 odd displaySizeId-7 odd-7 collapsed last"><meta content="News"><meta content="2017-07-07 20:26:05"><h4 class="wnContent headline"><a href="/story/35835718/mosquito-populations-increasing-across-lubbock"><span class="text">Mosquito populations increasing across Lubbock</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/35835718/mosquito-populations-increasing-across-lubbock"><span class="text">Mosquito populations increasing across Lubbock</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate updateddate"><label class="wnContent timestamp">Updated: </label><span class="wnContent timestamp servertime">Friday, July 7 2017 6:30 PM EDT</span><span class="wnContent timestamp gmttime">2017-07-07 22:30:03 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35835718/mosquito-populations-increasing-across-lubbock"><img border="0" width="90" data-path="http://kcbd.images.worldnow.com/images/14328494_G.jpg" title="Source: KCBD" alt="Source: KCBD"></a><span class="caption left width90"><span class="text">Source: KCBD</span></span></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35835718/mosquito-populations-increasing-across-lubbock"><img border="0" width="90" data-path="http://kcbd.images.worldnow.com/images/14328494_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>&nbsp;The recent rains across the South Plains were needed and appreciated. But, with the rain, comes more mosquitoes.</p></span></div><div class="wnContent summary"><span class="text"><p>&nbsp;The recent rains across the South Plains were needed and appreciated. But, with the rain, comes more mosquitoes.</p></span></div><div class="wnClear"></div></li><div class="wnItem toggle" data-number="3"><a class="text control open"> </a><a class="text control close"> </a><div class="wnClear"></div></div><div class="wnClear"></div></ul><div class="wnClear"></div></div><script>
                var ds = new Worldnow.CustomizedBlock('DisplaySizeId78');
                Worldnow.EventMan.event('displaysizeloaded',ds)
            </script><!--End of Display Size: Headline Box - Col 4 (78)--><div class="debug hide" data-debug="Display Size 66 attempting to load..."></div></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol4done');</script>
<!--END WNCol4-->
<div class="debug hide" data-debug="Display Size 35 attempting to load..."></div><div class="wnClearLeft"></div></div><!--END WNCols23-4--></div><!--END WNCols234-5-->
</div><!--END WNColsAll-->
<div id="WNFooter"><div id="WNCopyrightAlignment"><div id="WNCopyright"><table border="0" cellpadding="0" cellspacing="0"><tr><td style="vertical-align:top;"><a href="http://www.franklyinc.com" target="_blank"><img class="wnFooter" src="http://kcbd.images.worldnow.com/images/static/container-e/wn_powerby.gif" alt="Powered by Frankly" border="0"><img style="display:none;" class="wnFooter printable" src="http://images.worldnow.com/global/images/static/container-e/wn_powerby_printable.gif" alt="Powered by WorldNow" border="0"></a></td><td style="vertical-align:middle;"><div class="wnCopyrightText"><div id="CDEV-footer">
	<div class="top"> 
		<div class="search-box">
			<div class="wnSearchBox" id="WNSearchBox-bottom"><form method="get" onsubmit="return wnValidateSearchTerm(this,0)" action="/Global/searchresults.asp"><span>Can't Find Something? </span><input type="text" class="wnQueryText" name="qu" size="20" value="" placeholder="Search For It Here"><input type="submit" class="wnSubmit" value="Search"></form></div>			
		</div>
		<div class="station-info">
			<div class="logo"><img src="http://ftpcontent.worldnow.com/wncustom/custom/kcbd/2015/images/kcbd-footer-logo.png" width="103" height="98" border="0" /></div>
			<div class="contact">
				<div>5600 Avenue A<br>Lubbock, TX. 79404</div>
				<div>(806) 744-1414</div>
			</div>
			<div class="fcc">
				<div><a href="https://publicfiles.fcc.gov/tv-profile/kcbd">FCC Public File</a></div>
				<a href="mailto:publicfile@kcbd.com">publicfile@kcbd.com</a>
				<div>(806) 744-1414</div>
				<a href="/story/4693037/kcbd-eeo-public-file-report">EEO Report</a>
				<a href="/story/19485867/closed-captioning-on-kcbd-newschannel-11">Closed Captioning</a>
			</div>			
		</div>
	</div>
	<div class="footer-main-nav"> 
		<ul class="link-group">
			<!--<li><a href="#">News Now Link</a></li>
			<li><a href="#">News Now Link</a></li>
			<li><a href="#">News Now Link</a></li>
			<li><a href="#">News Now Link</a></li>-->
		</ul>
	</div>	
	<div class="news-link"> 
		<ul class="link-group">
			<li><a href="http://www.ktre.com/category/241993/texas-news-now">Texas News Now</a></li>
		</ul>
	</div>	
	<div class="bottom">
		<div class="copyrightText">
			<a id="wnLogo" href="http://www.worldnow.com"><img src="http://ftpcontent.worldnow.com/wncorp/logos/worldnow_white.png" id="wn"></a>
        	<div class="text">
				All content &copy; Copyright 2000 - 2017 Raycom Media. All Rights Reserved. For more information on this site, please read our <a href="/story/8774923/privacy-policy">Privacy Policy</a>, and <a href="/story/8775106/terms-of-service">Terms of Service</a>, and <a class="adchoice" href="//www.aboutads.info/choices" target="policy">Ad Choices</a>.
        	</div>
        	<div class="clear"></div>       
		</div>	
	</div>
</div></div></td></tr></table></div><div class="wnClear"></div></div><div class="wnClear"></div><!--END WNCopyright--></div><div id="WNFooterScripts"></div><!--END WNFooter-->
<!--
                Page Include: BODY--><script src="http://ftpcontent4.worldnow.com/raycom/js/global-footer.js"></script><!--
                END Page Include: BODY-->
<!--Customized Page Includes - Body-->
<script>(function(w){ var e = w.EventMan || null; var b = w.Beacon || null; e.event('analytics-body',b.get('page')); })(window.Worldnow || {});</script>
<script type="text/javascript">
                    if(Worldnow.EventMan){Worldnow.EventMan.event('bodydone');}
                </script></body></html>